re = /\n(?![^<]*<\/pre>)/m
str = '<p>Test contennt for regex
with line breaks</p>
<pre>code block
with multi line content
working fine</pre>
<pre class="brush:C#">
test line break before
open paranthesis < is not working fine
line breaks after paranthesis
is accepted
</pre>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result