#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*(?:-[A-Z\u00C0-\u00D6\u00D8-\u00DD][a-z\u00E0-\u00F6\u00F8-\u00FF]*)?$"
Local $sString = "Jean-Luc" & @CRLF & _
"J-L" & @CRLF & _
"J-Yes" & @CRLF & _
"Jean-Yves" & @CRLF & _
"Jean" & @CRLF & _
"Jyloup-P" & @CRLF & _
"Aurore D." & @CRLF & _
"Jean-louis" & @CRLF & _
"jean-pierre" & @CRLF & _
"Özil" & @CRLF & _
"Ôrore-Àko" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")