re = /[a-zA-Z]+@\w+\.com/m
str = 'CoreyMSchafer@gmail.com
corey.schafer@university.edu
corey-321-schafer@my-work.net
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end