using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\d+|(?:[^\w\s]|_)+|[^\W\d_]+";
string input = @"I2eat!Apples22becauseilike?Them
I2eat!Apples22becauseilike?ThemBLEU34.56";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}