// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d+(?:\.\d+)?|(?:[^\w\s]|_)+|[^\W\d_]+").unwrap();
let string = "I2eat!Apples22becauseilike?Them
I2eat!Apples22becauseilike?ThemBLEU34.56";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}