# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^.*(?=(?:\s+\S+){2}$)//gm;t' <<< "Level production data TD Index
Total Agriculture\Production data TS Index"