using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*(?=(?:\s+\S+){2}$)";
string substitution = @"";
string input = @"Level production data TD Index
Total Agriculture\Production data TS Index";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}