const regex = new RegExp('^.*(?=(?:\\s+\\S+){2}$)', 'gm')
const str = `Level production data TD Index
Total Agriculture\\Production data TS Index`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);