use strict;
my $str = 'Level production data TD Index
Total Agriculture\\Production data TS Index';
my $regex = qr/^.*(?=(?:\s+\S+){2}$)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";