$re = '/^[a-zA-Z_][a-zA-Z0-9_]*$/m';
$str = '2_pi
x_2
x___3
x 2
positionRobot
piece_presente
_commande_vanne
-courant_sortie
_alarme_
panne#2
int
défaillance
f\'
INT ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);