package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<\s*span[^>]*>(.*?)<\s*\/\s*span\s*>`)
var str = `<p nameIt="Title">Title_Test</p><figure class="t15"><table><thead><tr>
<th><span>Column1</span></th><th><span>Column2</span></th></tr></thead><tbody><tr><td><span>Entry1</span></td><td><span>Entry2</span></td><td><span>ready</span></td></tr><tr><td><span style="some:style;">Entry3</span></td><td><span style="another:style;">Entry4</span></td></tr></tbody></table></figure><p ex="ready">!aaa; `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}