// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)<\s*span[^>]*>(.*?)<\s*\/\s*span\s*>").unwrap();
let string = "<p nameIt=\"Title\">Title_Test</p><figure class=\"t15\"><table><thead><tr>
<th><span>Column1</span></th><th><span>Column2</span></th></tr></thead><tbody><tr><td><span>Entry1</span></td><td><span>Entry2</span></td><td><span>ready</span></td></tr><tr><td><span style=\"some:style;\">Entry3</span></td><td><span style=\"another:style;\">Entry4</span></td></tr></tbody></table></figure><p ex=\"ready\">!aaa; ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}