#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^(?:.{4})*$)^JVBER[a-zA-Z0-9\+\/]*={0,3}$"
Local $sString = "JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==" & @CRLF & _
"" & @CRLF & _
"JVBERiBUaGlzIG9uZSdzIHNob3J0" & @CRLF & _
"" & @CRLF & _
" NOT A MULTIPLE OF 4" & @CRLF & _
"JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQf==" & @CRLF & _
"" & @CRLF & _
" TOO MANY =" & @CRLF & _
"JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1w====" & @CRLF & _
"" & @CRLF & _
" WRONG STARTING TEXT" & @CRLF & _
"zVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==" & @CRLF & _
"" & @CRLF & _
" STRAY =" & @CRLF & _
"JVBERiBZb3Ugd2V=dCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ=="
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")