use strict;
my $str = 'JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==
JVBERiBUaGlzIG9uZSdzIHNob3J0
NOT A MULTIPLE OF 4
JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQf==
TOO MANY =
JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1w====
WRONG STARTING TEXT
zVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==
STRAY =
JVBERiBZb3Ugd2V=dCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==';
my $regex = qr/(?=^(?:.{4})*$)^JVBER[a-zA-Z0-9\+\/]*={0,3}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}