$re = '/(?=^(?:.{4})*$)^JVBER[a-zA-Z0-9\+\/]*={0,3}$/m';
$str = 'JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==
JVBERiBUaGlzIG9uZSdzIHNob3J0
NOT A MULTIPLE OF 4
JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQf==
TOO MANY =
JVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1w====
WRONG STARTING TEXT
zVBERiBZb3Ugd2VudCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==
STRAY =
JVBERiBZb3Ugd2V=dCBhbmQgZGVjb2RlZCB0aGlzPyBHb29kIGZvciB5b3UsIGNoYW1wIQ==';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);