const regex = /Error\.\d+\.Value :(.+?)(?:\\r|\\n|$)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('Error\\.\\d+\\.Value :(.+?)(?:\\\\r|\\\\n|$)', 'gim')
const str = `Error.0.Value : This is error for item 0.\\r\\nError.1.Value : This is error for item 1 and this item is exist.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}