use strict;
my $str = 'Error.0.Value : This is error for item 0.\\r\\nError.1.Value : This is error for item 1 and this item is exist.';
my $regex = qr/Error\.\d+\.Value :(.+?)(?:\\r|\\n|$)/imp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}