package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\n](.*):\s(.*)-.*(👤|💂|👼|⚡️|🐶|🐺☃️|🌝🐺|🐺|💋|🕵️|🔥|👶|👁|😼|☮️|🖕|🔫|🔮|🎭|🧑🔬|🙇|🎯|🦅|🎖| 🃏|🤕|🔪|👑|🧑|😈|👱🌚|👳|⚒|👷|🤯|💤|💘|🌀|📚|👨🔬)\s(.*)`)
var str = `بازیکن های زنده: 1 / 5
تست1: 💀 مرده - رمال 🦅 بازنده
تست2: فرار کرده - ریش سفید 📚 بازنده
تست3: 💀 مرده - شیمیدان 👨🔬 بازنده
تست4: 💀 مرده - پسر گیج 🤕 بازنده
تست5: 🙂 زنده - آتش زن 🔥 برنده
مدت زمان بازی: 00:05:31
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}