re = /^.*(?<!(w|W)orld).*(H|h)ome.*(\.|!)$/m
str = 'World is now behind you, the home is ahead!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end