# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/&#(\b174;)/®/;t' <<< "This is a registered company® and not for resale"