re = /&#(\b174;)/
str = 'This is a registered company® and not for resale'
subst = '®'
result = str.sub(re, subst)
# Print the result of the substitution
puts result