package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?sUm)(<a href="([^"]*)"\s*class="(?:[^"]* )?mfp_thumb.*(?: [^"]*)?"[^>]*>\s*([^\s].*?[^\s])\s*<\/a>)`)
var str = `blah blah <a href="test.html">Outside of scope</a> blah blah
<a href="/about/team/management/tony-georgis" class="mfp_thumb_pos_top" itemprop="url"><img src="/images/thumbnails/mod_minifrontpage/43_642_default.jpg" width="400" height="400" alt="Tony Georgis, P.E."></a>
blah blah <a class="test" id="one">Nothing</a> blah blah
`
var substitution = "{modal url="$2"}$3"
fmt.Println(re.ReplaceAllString(str, substitution))
}