Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
(?:(.*)\s+(&|\*)\s*const|(.*)(?:\s+)const(?:\s*)(&|\*)?)$
"
mg
Input 1
1
New
std::string const& std::string const const std::string& const char* std::unordered_map<int, EnhancedGameObject*> const* std::string * const char const *
Substitution
const \1\2\3\4