# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?!\A)\b(?=\p{Lu})/\n/gm;t' <<< "Français Langues bantoues Presse écrite Gabon Particularité linguistique"