# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[A-Z](([a-z0-9]+[A-Z]?)*)$"
test_str = ("ABCD\n"
"ABCDE\n"
"snake_case\n"
"camelCase\n"
"2PascalCase\n"
"streamIOIO\n"
"gREATERDtha\n"
"MdeADFAFdsADFads\n"
"DeviceSNSD\n"
"AabcABCD\n"
"AabcABCDabcABCD\n"
"ABabcABCD\n"
"ABabcABCDabcABCD\n"
"ABCabcABCD\n"
"ABCabcABCDabcABCDabcABCDabcABCD\n"
"ABCDabcABCD\n"
"ABCDabcABCDabcABCDabcABCDabcABCD\n"
"HTMLParser\n"
"ABabcABCDbcABC\n"
"ABCDabcABC\n"
"ABCDabcAB\n"
"ABCDabcA\n"
"AaABC\n"
"AabcABCabcABC\n"
"MoeADFdsADFads\n"
"ABCabcABC\n"
"ABCabcAB\n"
"ABabcABC\n"
"ABabcAB\n"
"AabcAB\n"
"ABCabcABCabcA\n"
"ABCabcA\n"
"AabcABC\n"
"AB\n"
"ABC\n"
"StreamIO\n"
"IOStream\n"
"DeviceID\n"
"DeviceSNS\n"
"IbsReleaseTestVerificationRegressioNSuite\n"
"CamelCA\n"
"CamelCa_1\n"
"Camel01CC01\n"
"HELLO\n"
"ContextHTMLParser\n"
"CreateAMode\n"
"CreateBMode\n"
"PacalCasePacalCasePacalCasePacalCasePacalCasePacalCase\n"
"A\n"
"Aabc123\n"
"Context\n"
"PascalCase\n"
"Pascal2Case\n"
"PascalCaseA\n"
"Pascal2CaseA\n"
"ModeA\n"
"Mode2A\n"
"Mode2A2\n"
"Mode2A2A\n"
"MadeEasy\n"
"WonderFul\n"
"AndMe\n"
"HtmlParser\n"
"H\n"
"AaA\n"
"Camel01C\n"
"Camel01c01\n"
"Camel01C01\n"
"Camel0a1c1\n"
"Camel0a1C1\n"
"Camel0ac1b1C1\n"
"CamelC\n"
"CamelC1\n"
"CamelCa1\n"
"IbsReleaseTestVerificationRegressionSuite\n"
"IbsReleaseTestVerificationRegressioN\n"
"XmlHttpRequest\n"
"NewCustomerId\n"
"InnerStopwatch\n"
"SupportsIpv6OnIos\n"
"YouTubeImporter\n"
"YoutubeImporter\n"
"Affine3D")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.