use strict;
my $str = 'A Kriel Street -25.69664263 28.41030434
Abraham Mogopodi Avenue -25.71338241 28.37033247
Absalome Street -25.70997386 28.3568847
Alan Paton Street -25.72122505 28.42021664
Alfred Nzo Crescent -25.6882444 28.41519928
Annah Mabusela Street -25.70656941 28.34339845
Anton Lembede Street -25.71813448 28.41874969
Aphane Nhlapo Street -25.7208474 28.38598257
Apple Close -25.71151327 28.38914898
Areyeng Street -25.72404151 28.38545561
Aseletho Street -25.71910848 28.41628606
Azikwelwa Street -25.70616386 28.40821879
Azondo Street -25.69615534 28.41117811
B Z Ndlazi Street -25.71074853 28.37073878
Badanile Avenue -25.71883255 28.42320088
Bahula Street -25.70728106 28.35488834
Baloyi Close -25.72553726 28.38641741
Bana Street -25.70942133 28.40631067
Banana Close -25.71194649 28.39090203';
my $regex = qr/^(?P<Street>(?:[A-Za-z\d]+\h)+)\h{2,}(?P<LAT>-?\d*\.\d+)\h{2,}(?P<LON>-?\d*\.\d+)$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}