import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "K(?=Y)([^\\/]*?)[0-9]{4}";
final String string = "JKan 1987\n"
+ "KYan this is /uaaaaaaaa 1987\n"
+ "KYanaaa this is aaaaaa 1987";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}