package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\p{Pd}`)
var str = `Vous êtes plutôt trait d'union (‐ U+2010), signe moins (- U+002D), tiret demi-cadratin (– U+2013), tiret cadratin (— U+2014) ou tiret numérique (‒ U+2012) ?`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}