use strict;
my $str = 'http://www.google.gr
https://www.google.gr
http://google.gr
http://www.google.gr/kino
http://www.google.co
http://google.co
http://google.gr
www.google.gr
www.google
http://www.google
http://google
www.google#.com
www.google.com
www.google-.gr
www.-google.gr
www.goo-gle.com
googel.gr
www.google.co
www.com
www.g.comwww.g.com
hello.com
.com
www.
www.google.comwww.google.com
';
my $regex = qr/(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9]\.[^\s]{2,})/ip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}