$re = '/(https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9][a-zA-Z0-9-]+[a-zA-Z0-9]\.[^\s]{2,}|https?:\/\/(?:www\.|(?!www))[a-zA-Z0-9]\.[^\s]{2,}|www\.[a-zA-Z0-9]\.[^\s]{2,})/i';
$str = 'http://www.google.gr
https://www.google.gr
http://google.gr
http://www.google.gr/kino
http://www.google.co
http://google.co
http://google.gr
www.google.gr
www.google
http://www.google
http://google
www.google#.com
www.google.com
www.google-.gr
www.-google.gr
www.goo-gle.com
googel.gr
www.google.co
www.com
www.g.comwww.g.com
hello.com
.com
www.
www.google.comwww.google.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);