using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?>(?P<scheme>[^:\/?#]+):(?=\/\/))?(?>\/\/)?(?>(?>(?P<login>[^:]+)(?::(?P<password>[^@]+)?)?@)?(?P<host>[^@\/?#:]*)(?::(?P<port>\d+)?)?)?(?P<path>[^?#]*)(?>\?(?P<query>[^#]*))?(?>#(?P<fragment>.*))?";
string input = @"https://ftpuserftp.trong.live:ftp.trong.live@ftp.trong.live:443/prv/test.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}