$re = '/^\#([\s]+)+(.*)$/m';
$str = '# Some title here
- Show: Show name here
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);