using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<p>(\s*)(<a(.*)>)?(\s*)(https?:\/\/)?(w{3}\.)?(instagram\.com)\/(p\/)?(?<photoID>[A-Za-z0-9-_]{11})(\S*)(\s*)(<\/a>)?(\s*)?<\/p>";
string input = @"Best case
<p>https://www.instagram.com/p/B9XK4J3jVui/</p>
Whitespace
<p>
https://www.instagram.com/p/B9XK4J3jVui/
</p>
Protocol variations
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>www.instagram.com/p/B9XK4J3jVui/</p>
<p>instagram.com/p/B9XK4J3jVui/</p>
Trailing slash or not
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>http://www.instagram.com/p/B9XK4J3jVui</p>
Linked
<p><a href=""http://www.instagram.com/p/B9XK4J3jVui/"">http://www.instagram.com/p/B9XK4J3jVui/</a></p>
<p>
<a href=""http://www.instagram.com/p/B9XK4J3jVui/"">
http://www.instagram.com/p/B9XK4J3jVui/
</a>
</p>
Extraneous URL params
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar</p>
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar&baz=buzz</p>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}