use strict;
my $str = 'Best case
<p>https://www.instagram.com/p/B9XK4J3jVui/</p>
Whitespace
<p>
https://www.instagram.com/p/B9XK4J3jVui/
</p>
Protocol variations
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>www.instagram.com/p/B9XK4J3jVui/</p>
<p>instagram.com/p/B9XK4J3jVui/</p>
Trailing slash or not
<p>http://www.instagram.com/p/B9XK4J3jVui/</p>
<p>http://www.instagram.com/p/B9XK4J3jVui</p>
Linked
<p><a href="http://www.instagram.com/p/B9XK4J3jVui/">http://www.instagram.com/p/B9XK4J3jVui/</a></p>
<p>
<a href="http://www.instagram.com/p/B9XK4J3jVui/">
http://www.instagram.com/p/B9XK4J3jVui/
</a>
</p>
Extraneous URL params
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar</p>
<p>https://www.instagram.com/p/B9XK4J3jVui?foo=bar&baz=buzz</p>';
my $regex = qr/<p>(\s*)(<a(.*)>)?(\s*)(https?:\/\/)?(w{3}\.)?(instagram\.com)\/(p\/)?(?<photoID>[A-Za-z0-9-_]{11})(\S*)(\s*)(<\/a>)?(\s*)?<\/p>/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}