# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(>)(|[^\S\r\n]+)(<\\/)/\1[!] value does not exist!\3/gs;t' <<< " <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<any_other_tag></any_other_tag>
<any_other_tag> </any_other_tag>
<segments>0000</segments>
</file>"