import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(>)(|[^\\S\\r\\n]+)(<\\/)";
final String string = " <file> \n"
+ " <fileType>Mezza</fileType>\n"
+ " <fileName></fileName>\n"
+ " <any_other_tag></any_other_tag>\n"
+ " <any_other_tag> </any_other_tag>\n"
+ " <segments>0000</segments>\n"
+ " </file>";
final String subst = "\\1[!] value does not exist!\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}