use strict;
my $str = ' <file>
<fileType>Mezza</fileType>
<fileName></fileName>
<any_other_tag></any_other_tag>
<any_other_tag> </any_other_tag>
<segments>0000</segments>
</file>';
my $regex = qr/(>)(|[^\S\r\n]+)(<\/)/sp;
my $subst = '\\1[!] value does not exist!\\3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";