#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)turned\s+into\s+a\s+democracy"
Local $sString = "Lorem ipsum dolor sit amet, consectetur adipiscing turned into a democracy " & @CRLF & _
"elit, sed do eiusmod tempor incididunt ut labore" & @CRLF & _
"" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipiscing turned into " & @CRLF & _
"a democracy elit, sed do eiusmod tempor incididunt ut labore" & @CRLF & _
"" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipiscing turned into a " & @CRLF & _
"democracy elit, sed do eiusmod tempor incididunt ut labore" & @CRLF & _
"" & @CRLF & _
"Lorem ipsum dolor sit amet, consectetur adipiscing turned " & @CRLF & _
"into a " & @CRLF & _
"democracy elit, sed do eiusmod tempor incididunt ut labore"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")