re = /turned\s+into\s+a\s+democracy/m
str = 'Lorem ipsum dolor sit amet, consectetur adipiscing turned into a democracy
elit, sed do eiusmod tempor incididunt ut labore
Lorem ipsum dolor sit amet, consectetur adipiscing turned into
a democracy elit, sed do eiusmod tempor incididunt ut labore
Lorem ipsum dolor sit amet, consectetur adipiscing turned into a
democracy elit, sed do eiusmod tempor incididunt ut labore
Lorem ipsum dolor sit amet, consectetur adipiscing turned
into a
democracy elit, sed do eiusmod tempor incididunt ut labore'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end