import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\"--CVP.*(<sip:.*@.*)";
final String string = "\"--CVP_11_5_1_0_1_0_349\" <sip:05335816023@10.134.27.2>;tag=1417F2E5-2588\n"
+ "\"Emre Sumengen\" <sip:3321@10.134.27.2>;tag=1417F2E5-2588\n"
+ "\"--CVP_13_00xx..ssdadsalds_349\" <sip:05335816023@10.134.27.2>;tag=1417F2E5-2588\n";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}