const regex = /\"--CVP.*(<sip:.*@.*)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\"--CVP.*(<sip:.*@.*)', 'g')
const str = `"--CVP_11_5_1_0_1_0_349" <sip:05335816023@10.134.27.2>;tag=1417F2E5-2588
"Emre Sumengen" <sip:3321@10.134.27.2>;tag=1417F2E5-2588
"--CVP_13_00xx..ssdadsalds_349" <sip:05335816023@10.134.27.2>;tag=1417F2E5-2588
`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);