// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\"--CVP.*(<sip:.*@.*)"#).unwrap();
let string = "\"--CVP_11_5_1_0_1_0_349\" <sip:05335816023@10.134.27.2>;tag=1417F2E5-2588
\"Emre Sumengen\" <sip:3321@10.134.27.2>;tag=1417F2E5-2588
\"--CVP_13_00xx..ssdadsalds_349\" <sip:05335816023@10.134.27.2>;tag=1417F2E5-2588
";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}