$re = '/[1-9]+\d*[.,]\d{2}(?!0)/m';
$str = '12.34
12.340 //BAD - Zero cannot be the first character
12.345 //OK - I want 5 to be discarded
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);