use strict;
my $str = 'Disinfecting Wipes Lemon Fresh 35 pkg 3.39
Ultra Liquid Bleach Mountain Fresh 96 oz 2.39
FF & LS Broth Chicken 32 oz 2.99';
my $regex = qr/\b(\S+(?: ?\S+)*)\b/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}