#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?sx)(?'a'[~_])(?=" & @CRLF & _
" (?'d'(?!\s)(?:(?!\k'a').)+(?<!\s)\k'a') |" & @CRLF & _
" (?=(?'b'.*))(?'c'" & @CRLF & _
" ^(?>\k'a'(?&d)|.)*\k'a'(?&d)(?=\k'b'\z) |" & @CRLF & _
" (?<=(?=x^|(?&c)).)" & @CRLF & _
" )" & @CRLF & _
")"
Local $sString = "~target~" & @CRLF & _
"~target~adjacent is not target~" & @CRLF & _
"begining with space ~ target~" & @CRLF & _
"ending with space ~target ~" & @CRLF & _
"empty ~~" & @CRLF & _
"divided by two lines _tar" & @CRLF & _
"get_" & @CRLF & _
"without closing delimiter ~target" & @CRLF & _
"with mixed delimiters ~_target~_" & @CRLF & _
"with nested delimiters ~_target_~"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")