using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?'a'[~_])(?=
(?'d'(?!\s)(?:(?!\k'a').)+(?<!\s)\k'a') |
(?=(?'b'.*))(?'c'
^(?>\k'a'(?&d)|.)*\k'a'(?&d)(?=\k'b'\z) |
(?<=(?=x^|(?&c)).)
)
)";
string input = @"~target~
~target~adjacent is not target~
begining with space ~ target~
ending with space ~target ~
empty ~~
divided by two lines _tar
get_
without closing delimiter ~target
with mixed delimiters ~_target~_
with nested delimiters ~_target_~";
RegexOptions options = RegexOptions.Singleline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}