Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\d{4}-\d{2}-\d{2})(\s|T|t)(\d{2}:\d{2}(?::\d{2})?)?
/
g
Test String
New
2016-02-01 2016-02-01 00:00 2016-02-01T00:00 2016-11-10 12:30:11 2016-02-01T12:30:11