re = /^((?<emoji_left>(?::\w*:|\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55]))\s)?(?<type>\w+)(?:\((?<scope>[^)]*)\))?!?:\s((?<emoji_center>(?::\w*:|\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55]))\s)?(?<subject>(?:(?!#).)*(?:(?!\s).))(?:\s(?<ticket>#(?<ticket_number>\w+)|\(#(?<ticket_number>\w+)\)))?(?:\s(?<emoji_right>(?::\w*:|\ud83c[\udf00-\udfff]|\ud83d[\udc00-\ude4f\ude80-\udeff]|[\u2600-\u2B55])))?$/m
str = 'chore(scope): test
chore(scope)!: test
chore!: test
chore!(scope)!: test
hello: :test: test #111 ✨
:start: test: 1wsdwqs #11111
✨ feat(unicode): ✨ adasas sfsd :das: #1d1w ✨
feat(unicode): add unicode suppdadass o # (#rtasa) ✨
:hello: test: test
:start: chore(scope): test
:start: chore(scope): test #123
:memo: docs: update README.md
:start: chore(scope): i have a word #123
:package: feat(parser-opts): extract parser-opts packages
:sparkles: feat(changelog): 添加中文标题
:sparkles: feat(changelog): add chinese title
✨ feat(unicode): add unicode support
😌 test(only): add unicode support
:sparkles: feat: hello world (#100)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end