use strict;
my $str = 'this is a blabla (32332) [XAML]';
my $regex = qr/[\]()\[]+/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";