use strict;
my $str = 'ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ.อุบล 34000
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จังหวัดอุบล 34000
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ. อุบล 34000
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จังหวัด อุบล 34000
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กรุงเทพ 34000
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กทม 34000
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จังหวัดกรุงเทพมหานคร 34000
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กทม. 34000
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง กรุงเทพมหานคร34000
ประสิทธิ์ เขมศักดิ์ 4/32 ซอยสุขสวัสดิ์ ต.หัวเรือ อ.เมือง จ อุบล 34000
ราตรี แสนเล็ก 39หมู่11ซ.บูรพา1 แม่กุ แม่สอด ตาก 63110 0924468731
กันธิชา. ฤกษจันทร์ 64/10พุนพินมะลวนสุราษฎร์ธานี8413066936166649, พุนพิน';
my $regex = qr/((?<=จังหวัด\s)|(?<=จังหวัด)|(?<=จ\.\s)|(?<=จ\.)|(?<=จ\s))([ก-๙]+)|(กรุงเทพ[มหานคร]*)|(กทม)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}